[Logo] SpagoWorld Forums
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
[Groups] Back to home page  [Moderation Log] Moderation Log   [Register] Register /  [Login] Login 
Messages posted by: rapidoss.spw
Forum Index » Profile for rapidoss.spw » Messages posted by rapidoss.spw
Author Message
Hi all,

i have installed SpagiBI in production machine, i can access to some reports and not to others.

I get this error:

Error occured while retrieving user profile of user [xx] from service [Security Service] at endpoint [http:/xx.x.xx/SpagoBI/services/SecurityService]; Cause: (403) Forbidden


pleas any help with that??
Hi ,

I agree with u , i have problems with Highchart engine as well.


Error
Error Highcharts Engine not available

Description: Highcharts Engine not contained in this distribution. If you want to use Highcharts in this distribution please contact SpagoBI Labs



i don't know what to do to integrate Highcharts engine in this distribution.
hi Luca, thanks for u replay

but even with that the join automatically is not working well.

i'm getting this error :

An unpredicted error occurred while executing EXEC_QUERY_ACTION service. The root cause of the error is: Impossible to auto join entities

any ideas with that??

thanks.
hi all ,

i want to know why the qbe hierarchy does not exist in the new version of spagobi 4.



need help.

thanks in advance
hi ,

i have the same problem , i think the new qbe relationship is not working?!!

any Help with that.
Hi all,

i'm traying the new version of qbe , by creating a business model.

so the query is not executed , and i'm not getting the relationship between tables.

not : i'm using the new spagobi studio and server.

any halp with that.
Hi All,

i want to migrate from my old version of spagobi server 3.6 to the new one 4 , i want to import my reports&Data using the import/export tool but i getting this error:

Error in retrieving exported bi objects from table SbiDataSet

i guess there is a changement in the schema of some tables like sbi_data_set.

how can i deal with that??

thanks.
Hi xogutu, thanks for u replay.

i'm not using birt report, my question is :

is that possible to go from one chart (a pie for exemple) used in composite document to many composite document.

thanks.
HI ,
i guess that i have the same problem.

well , i have one document composite that contains many charts.

i want if i click in a chart i can go to different document composite depending on Category business i choose.

or maybe if there is possibility to do if condition in document composite to switch between charts

thanks.
Hi sraavsarma,

the source code can be downloaded in : http://forge.ow2.org/project/showfiles.php?group_id=204 under SpagoBI 3.6.0 - Source.

when you get the source unziped it : then you found SpagoBIProject repository , you have to use Eclipse to make changes i said before in my last post.

the java class : it\eng\spagobi\analiticalmodel\execution\service\ExecuteAndSendAction.java

and u have just to follow the steps.

Hope that i help , i'm here for any others questions.
Hi All,

i resolve the problem of STARTTLS

you have to change in source code of spagobi.core-3.6.0.jar under webapps\SpagoBI\WEB-INF\lib (for that u can download the source project).

the main problem is under class : it\eng\spagobi\analiticalmodel\execution\service\ExecuteAndSendAction.java

so you have to add this line of code : props.put("mail.smtp.starttls.enable", "true"); , compile the class .

finally u have to add three file .class under to same location it\eng\spagobi\analiticalmodel\execution\service\ in the .jar file spagobi.core-3.6.0.jar:

* ExecuteAndSendAction$SchedulerDataSource.class
* ExecuteAndSendAction$SMTPAuthenticator.class
* ExecuteAndSendAction.class

Now the mail can be send correctly .

one more thing , the mail format will be sent as HTML , to change it to PDF u have to add a new analitical driver in your document detail . Its name should be 'outputType' and its value should be 'PDF'. In this way, without other modifies, you tell to the report engine that the output format is PDF (the default value is HTML).
see this issue : http://www.spagoworld.org/jforum/posts/list/199.page#608

hope that hepls .
Hi All,

i resolve the problem of STARTTLS

you have to change in source code of spagobi.core-3.6.0.jar under webapps\SpagoBI\WEB-INF\lib (for that u can download the source project).

the main problem is under class : it\eng\spagobi\analiticalmodel\execution\service\ExecuteAndSendAction.java

so you have to add this line of code : props.put("mail.smtp.starttls.enable", "true"); , compile the class .

finally u have to add three file .class under to same location it\eng\spagobi\analiticalmodel\execution\service\ in the .jar file spagobi.core-3.6.0.jar:

* ExecuteAndSendAction$SchedulerDataSource.class
* ExecuteAndSendAction$SMTPAuthenticator.class
* ExecuteAndSendAction.class

Now the mail can be send correctly .

one more thing , the mail format will be sent as HTML , to change it to PDF u have to add a new analitical driver in your document detail . Its name should be 'outputType' and its value should be 'PDF'. In this way, without other modifies, you tell to the report engine that the output format is PDF (the default value is HTML).
see this issue : http://www.spagoworld.org/jforum/posts/list/199.page#608

hope that hepls .
Hi

I have exactly the same problem: use to send mail through 'Gmail account' .

please help us with this issue

thnks
hi all ,

i have to same problem , could anyone please tell us what to do ?!!!

i already configured Mail(smtp, port ...)., but i still have to same problem of STARTTLS

thanks.
thanks u , it's help a lot

so i want to use the same approch in QBE (datamart)

How can i do that??!!

thanks in advance
 
Forum Index » Profile for rapidoss.spw » Messages posted by rapidoss.spw
Go to:   
Powered by JForum 2.1.9 © JForum Team