[Logo] SpagoWorld Forums
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
[Groups] Back to home page  [Moderation Log] Moderation Log   [Register] Register /  [Login] Login 
SpagoBI 5.1: Error generating QBE-Query.  XML
Forum Index » Technical Help - SpagoBI Server - AD HOC REPORTING
Author Message
achilie.spw

Newby

Joined: 01/10/2015 11:22:16
Messages: 12
Offline

Hello,

Maybe someone can help.
I Mam using SpagoBI-Server 5.1, Oracle 11.2.
I have created a Business Model with 2 Tables.
The first Table is summary_person with a primary_key id_person. The second Table is named datasheet with
a Column id_owner. The id_owner is the id_person in the Table summary_person.
I have created an outbound Relationship.

I can deploy the Model to the Server. When i click on the generated query in the QBE the following Error occurs:

An unpredicted error occurred while executing GET_SQL_QUERY_ACTION service.
The root cause of the error is: could not resolve property: ID_OWNER of:
it.eng.spagobi.meta.Summary_person
[SELECT t_0.ID_PERSON, t_1.ID_DATASHEET
FROM it.eng.spagobi.meta.Summary_person t_0,it.eng.spagobi.meta.Datasheet t_1
WHERE (t_1.rel_ID_PERSON_in_datasheet.ID_OWNER = t_0.rel_ID_PERSON_in_datasheet.ID_PERSON)]


My guess is, that if the names of the join condition are not equal it comes to this Error.
Can someone confirm this?

Thanks in advance
Joachim
 
Forum Index » Technical Help - SpagoBI Server - AD HOC REPORTING
Go to:   
Powered by JForum 2.1.9 © JForum Team