[Logo] SpagoWorld Forums
  [Search] Search   [Recent Topics] Recent Topics   [Hottest Topics] Hottest Topics   [Members]  Member Listing  
[Groups] Back to home page  [Moderation Log] Moderation Log   [Register] Register /  [Login] Login 
Cross Navigation -> Unable to pass category if it has ampersand  XML
Forum Index » Technical Help - SpagoBI Server - CHART & DASH
Author Message
sadiqkhoja.spw

Newby

Joined: 11/03/2013 14:33:21
Messages: 29
Offline

It seems that there is bug in Cross Navigation. If my category contains ampersand (&) then only characters before it are passed to next document. For Example:



when user clicks on first column then



which says Analytical Driver Zone can't assume value 'A' however first chart should be sending 'A & B'

Thanks
Sadiq Khoja
aghedin

SpagoBI hero
[Avatar]

Joined: 14/07/2010 09:25:00
Messages: 465
Offline

It happens because the & is a separator in the cross navigation url..
I’ve created a bug in jira (http://www.spagoworld.org/jira/browse/SPAGOBI-1102)
In the meanwhile you can try to escape the & characters in the dataset..

Alberto Ghedin

~~~ sis felix ~~~
terje.spw

Newby
[Avatar]

Joined: 05/06/2012 15:19:35
Messages: 18
Location: Oslo, Norway
Offline

I get a similar error message when the category contains Norwegian letters - like æ,ø and å.

The preferred solution would be to separate the categories from the labels printed on the screen, so that the values passed in the cross-reference are e.g. Category IDs, and the values shown in the graph are e.g. Category Names. I have not found a way to do this yet, though, so I am using workarounds (e.g. using Tool Tips for Names and Alias for IDs)
[WWW]
 
Forum Index » Technical Help - SpagoBI Server - CHART & DASH
Go to:   
Powered by JForum 2.1.9 © JForum Team